Excluding GIT files

Do you have anything to share with other users? Your opinions about our programs, suggestions for future products - everything goes here.
Post Reply
rfossella
Posts: 10
Joined: Fri Mar 11, 2011 6:27 pm

Excluding GIT files

Post by rfossella »

Hi,

While using SynchronizeIt I'm trying to exclude my GIT repository folders and files. My filter is set like this: !.git

I've used exclude filters for a long time but cannot seem to ignore these. I'm sure it has to do with the fact that these folders have no "base" name - i.e. "dot" names. See attached snapshot.

Is there a way to properly set up this filter?

Thanks.
Rob
Attachments
gitFiles.jpg
gitFiles.jpg (90.55 KiB) Viewed 15443 times

TonHu
Posts: 100
Joined: Mon Sep 29, 2003 10:48 am
Location: Netherlands

Re: Excluding GIT files

Post by TonHu »

For excluding svn folders I have set a folder-exclusion of *\.svn\, and I'd probably set a similar exclusion for git if I were using Git :wink:

grigsoft
Site Admin
Posts: 1661
Joined: Tue Sep 23, 2003 7:37 pm
Contact:

Re: Excluding GIT files

Post by grigsoft »

That's right, you should use exclude folders options, not exclude files, and just ".git" would work.

rfossella
Posts: 10
Joined: Fri Mar 11, 2011 6:27 pm

Re: Excluding GIT files

Post by rfossella »

Many thanks! Adding the exclude filter of *\.git\ did the trick.

Rob

Post Reply