Projects and removeable drives

Discussion of new Synchronize It! version.
JPG
Posts: 109
Joined: Tue May 23, 2006 7:06 am

Projects and removeable drives

Postby JPG » Tue May 23, 2006 7:55 am

I am trying to sync files from a secure digital card to a fixed Hard disk, and a usb Hard disk. I created a project and it all seemed to work ok. Then I removed the usb Hard disk and ran the project. ( I had put new files on the SD card). "no files to sync". I found that if I changed the order of the project files -- moved the usb Hard disk session to the last position, then new files were picked up. But drive not found was not flagged. So I suppose the program needs to deal with removable drives that it finds are no longer connected.
Version I am trying is 3.02

Wilhelm

Postby Wilhelm » Tue May 23, 2006 10:23 am

Do I understand you correctly? You started with a SD Card and a USB harddisk attached to your system, then you removed ONLY the harddisk, so that the drive letter of the card did NOT change? Still the project did not work any longer? If so, this is a mystery to me...
(If the drive letter of the card did change, than it's a trivial problem. )

Guest

Postby Guest » Tue May 23, 2006 11:41 am

Wilhelm wrote:Do I understand you correctly? You started with a SD Card and a USB harddisk attached to your system, then you removed ONLY the harddisk, so that the drive letter of the card did NOT change? Still the project did not work any longer? If so, this is a mystery to me...
(If the drive letter of the card did change, than it's a trivial problem. )


All drive letters stay the same.
As I tried to explain, the project will just silently fail when it reaches the missing drive, so if you put it first in the project sequence it says " no files were found to synchronize!"..... moving it down the list of three allows the first "session" to be processed, then it silently fails on the next two.
Moving it to the last position, allows two parts to be processed. But there is still no warning that it has not found the drive that I have disconnected.
This is a mystery to me also, because if I try to run the session file, it will flag that there is no drive " Folder is not valid! do you want to create it?

grigsoft
Site Admin
Posts: 1671
Joined: Tue Sep 23, 2003 7:37 pm

Postby grigsoft » Tue May 23, 2006 1:16 pm

Thank you all, I have understood the problem and will try to fix it.


Return to “Synchronize It! : beta”

Who is online

Users browsing this forum: No registered users and 1 guest