Subfolders not being searched

Post your bug reports here

Subfolders not being searched

Postby txbd75 » Sun Jan 24, 2010 3:25 pm

I'm using version 3.5.1698. Occasionally, the software will report back that folders between two machines are identical without checking the subfolders. Other times, it reads the entire subfolder tree just like it should. Any thoughts?
txbd75
 
Posts: 4
Joined: Sat Jan 23, 2010 5:24 pm

Re: Subfolders not being searched

Postby grigsoft » Sun Jan 24, 2010 5:05 pm

How do you know folders were not searched? Are you using any folders filters? I assume you do not change"include subfolders" option on Start dialog?
Also, if you rescan same folders several times, will problem appear?
grigsoft
Site Admin
 
Posts: 1661
Joined: Tue Sep 23, 2003 7:37 pm

Re: Subfolders not being searched

Postby txbd75 » Fri Jan 29, 2010 11:55 pm

The folders that I'm comparing have about 20K files in them and several hundred folders. When it works right, it takes 20-30 seconds. I turned on the machine tonight for the first time in a week and I immediately got the "Folders seem identical" message. I know that I added files to my subfolders during the week. Also, there was no chance for a cache to be created, which can make it go faster. The 'include subfolders' is, of course, checked.

I tried repeatedly clicking Rescan (F5) and it doesn't work. I'm starting it from a .BAT file. The line being executed is:

"C:\Program Files (x86)\Synchronize It!\wndsync.exe" d:\Files\Work n:\Files\Work /scan /r /date

Thoughts? Anything else I can check?
txbd75
 
Posts: 4
Joined: Sat Jan 23, 2010 5:24 pm

Re: Subfolders not being searched

Postby grigsoft » Sat Jan 30, 2010 11:40 am

You don't specify file mask or session - last used file mask will be reused then. Review options on Start dialog, or show same files - maybe you will see that not all files are being scanned.
grigsoft
Site Admin
 
Posts: 1661
Joined: Tue Sep 23, 2003 7:37 pm

Re: Subfolders not being searched

Postby grigsoft » Sat Jan 30, 2010 11:43 am

Maybe it doesn't search recursive for some reason?
grigsoft
Site Admin
 
Posts: 1661
Joined: Tue Sep 23, 2003 7:37 pm

Re: Subfolders not being searched

Postby txbd75 » Sat Jan 30, 2010 12:19 pm

Argh..... Yep, there was a filter turned on to exclude folders for another search pair of folders (never got exclude folders to work, but the filter was still there). Thanks for pointing me in the right direction. That fixed it.

Thanks!!!
txbd75
 
Posts: 4
Joined: Sat Jan 23, 2010 5:24 pm

Re: Subfolders not being searched

Postby grigsoft » Sat Jan 30, 2010 12:32 pm

That's why Sessions exist. if you often sync same pairs, configure session and use it.
grigsoft
Site Admin
 
Posts: 1661
Joined: Tue Sep 23, 2003 7:37 pm


Return to Synchronize It! : Bug reports

Who is online

Users browsing this forum: No registered users and 1 guest