Really bad performance when downloading big files

Post your bug reports here
EeOe
Posts: 79
Joined: Tue May 23, 2006 6:41 pm

Really bad performance when downloading big files

Postby EeOe » Mon Aug 04, 2008 10:22 am

I noticed that while Synchronize It! is downloading big files (e.g 50MB) form FTP server the download speed is constantly dropping. I also noticed that while it's downloading Synchronize It! CPU usage will quickly rise up to 100% which is probably is eating all the download speed.

To try it. Download any big file from FTP server.
E.g. from here: ftp://ftp.scene.org/pub/parties/2008/assembly08/short

When I downloaded some file from there with Synchronize It! the download speed dropped from ~170 kbs to ~50 kbs (and it kept dropping) within couple of minutes. But when I tried Firefox and one other FTP program to download the same file I got constant ~170 kbs speed.

grigsoft
Site Admin
Posts: 1671
Joined: Tue Sep 23, 2003 7:37 pm

Postby grigsoft » Tue Aug 05, 2008 9:54 am

Thank you, I have never checked this myself. I will check what could be a reason.

EeOe
Posts: 79
Joined: Tue May 23, 2006 6:41 pm

Postby EeOe » Tue Aug 05, 2008 10:58 am

I did some more digging and it seems that this problem isn't related to the file size at all, but the problem is more obvious with big files. What I found out is that faster you download, more CPU time Synchronize It! is using. Which actually makes much more sense.

If the download speed is ~80 kbs the CPU usage is 5-10% and the download speed never drops. When the download speed is ~200 kbs the CPU usage jups to 100% almost instantly and starts to eat the download speed, but it doesn't give CPU time back. It's a vicious circle.

funiculargoat
Posts: 1
Joined: Wed Sep 30, 2009 5:08 pm

Postby funiculargoat » Wed Sep 30, 2009 5:16 pm

I'm seeing exactly the same behavior described by EeOe, using S-It! 3.4.1640 (unicode).

Typically, my PC and notebook are on the same LAN, so FTP transfers of around 1MB/sec are theoretically possible. Indeed, when I start the synchronize process, the transfer rate approaches that. But it rather quickly follows the vicious cycle described above ... CPU utilization goes through the roof, and transfer rates dive downward.

Eventually the xfer rate settles on a pretty slow number (about 40KB/sec, usally), but the cpu utilization never dips below 100% until the transfer completes.

With large files (for example, 30M or more), the degraded performance results in making s-it! really a pain to use :( I love everything else about s-it!, and really want to stick with it.

Any chance of addressing this issue?

Thanks!
-Bob
Andover, MA usa

grigsoft
Site Admin
Posts: 1671
Joined: Tue Sep 23, 2003 7:37 pm

Postby grigsoft » Thu Oct 01, 2009 3:43 am

Thank you, guys, I'm working on it.

grigsoft
Site Admin
Posts: 1671
Joined: Tue Sep 23, 2003 7:37 pm

Postby grigsoft » Sun Oct 04, 2009 8:18 am

Does this happen with latest beta from http://www.grigsoft.com/wndsyncbu.zip ?

EeOe
Posts: 79
Joined: Tue May 23, 2006 6:41 pm

Postby EeOe » Sun Oct 04, 2009 5:15 pm

grigsoft wrote:Does this happen with latest beta from http://www.grigsoft.com/wndsyncbu.zip ?

This problem appears to be fixed in the latest beta. CPU usage stays calm and download speed stays up. :)

Thank you very much for fixing this problem.

johns123
Posts: 1
Joined: Thu Oct 22, 2009 1:02 pm
Location: LUDHIANA
Contact:

yes,you are right

Postby johns123 » Mon Oct 26, 2009 12:52 pm

Hi,

i think you are right.i always notify that while downloading through FTP the speed of net always gone slow.

TY!


Return to “Synchronize It! : Bug reports”

Who is online

Users browsing this forum: No registered users and 1 guest