Page 1 of 1

Problem with quotation marks

Posted: Wed Oct 17, 2007 9:09 pm
by digitalfreak

i am using wndsync with my Total Commander and I have some Problems with pathes that have spaces.
Normaly TC starts wndsync like this:

wndsync c:\ d:\ /cnt

No problem so far, this works.

For the case that there may spaces in the pathes I put all into quotation marks like this:

wndsync "c:\" "d:\" /cnt

I now get an Error "Can not find Project or Session by this name! c:" d:"

The problem seem to be the backslash at the end of the pathes. TC always put the backslash at the end of the path.

Posted: Thu Oct 18, 2007 4:13 am
by grigsoft
Have you checked this - ?

"%P\" "%T\" is working just fine for me.

Posted: Thu Oct 18, 2007 1:05 pm
by digitalfreak
I don't have problems starting Compare It.

Please try starting wndsync from a command prompt:

wndsync "c:\" "d:\" /cnt

This is the way TC would start wndsync with the parameter line:
"%P" "%T" /cnt

Using this paramter line:
"%P\" "%T\"
would result in a wndsync "c:\\" "d:\\"

But... it works. Why do I have to double the backslash? And why is this only needed if you use quotation marks? wndsync c:\ d:\ /cnt is working, too.

Posted: Fri Jun 19, 2009 11:30 am
by Spitfire_ch
Awesome, thank you!

After so many years, another guy had to idea to start SynchronizeIt! From within Total Commander (me) ... and ran into the exact same problems. But your trick with adding another backslash ("%P\" "%T\") worked perfectly, thank you!

- spitfire

Posted: Tue Jun 23, 2009 12:03 pm
by digitalfreak

nice to see that my experiences with TC helped you.
I wonder that Mr. Green dind't fixed that problem. I don't think that this behavior is what it is suposed to be.
But anyway, Synchronize It! is a very good piece of software.